[Front] [Prev Chapter] [Next Chapter]

Chapter 21 Using the Network

This chapter describes the various tasks you can perform when using the Caldera DR-DOS network. To understand this information, you do not need to have read the previous chapter, Chapter 20, "Setting Up the Network," but you need to be familiar with the terms and concepts described in Chapter 18, "Introduction to Personal NetWare." The following is a list of the tasks described in this chapter.

Logging In

You must load the network software before you can log in to the network.

Providing a Password for Security

When you start the operating system, your computer determines whether or not security has been enabled on it. If it has, you are asked to provide a password. If your computer is a server, it may have a list of users who are allowed to use it. If so, you are asked for your username as well as your password.

You must type your user password, not the computer's Master Key Password, to take advantage of the one-time login feature described in the next section. Refer to "Configuring a Server" on page 20-14 for information about how to set up security.

Loading Network Software

Once the DR-DOS network software has been installed and enabled (as described in Chapter 3, "Installing Personal NetWare"), you are asked whether or not you want to load it, every time you start the operating system.

If you answer N (for No), you can use your computer exactly as you did before you enabled the network software. None of the network software is in your computer's memory so you have the maximum amount of memory available to run applications. If you decide later that you want to use the network, simply type the following command at the system prompt:

STARTNET <Enter>

This command loads the network software, just as though you had answered Y to "Load Network Software?"

IMPORTANT: If you answer Y, or later run STARTNET, the network software is loaded into your computer's memory. If your computer is set up as a Personal NetWare server, other users can connect to it from this point.

Task Switching: Local and Global Connections

IMPORTANT: You cannot load the network software while the Task Manager or a similar program is running. You must first unload the Task Manager, which means you must close all your tasks. After loading the network software you can load the Task Manager.

All network connections made before you load the Task Manager are global, so you can use shared printers and directories in any task. Any connections you make subsequently are, by default, local to the task in which they are made. Each task has its own copy of the global connections, so changes made within one task do not affect other tasks. You can delete or change drive and printer connections without affecting other tasks. You can print to the same or different printers simultaneously from different tasks.

This can greatly increase the number of connections to Personal NetWare servers, which each support only a preset number of connections. It might be necessary to increase that number if many clients use task switching. See "Configuring a Server" on page 20-14.

Under MS Windows in enhanced (386*) mode, you can choose whether you want connections to be local to each task or global. Global connections are the same in each application and DOS window, even those already running when you make or change a connection. Thus, for example, changing the current directory on a drive in one DOS window affects all other windows if connections are global.

Note that if you run several NetWare®-aware applications that communicate with NetWare servers at a low level (the IPX level), you must run the supplied program TBMI2.COM in order that they may work together correctly under the Task Manager. See Chapter 13, "Multitasking and Task Switching," for details about the Task Manager.

Logging In to the Network

When the network software is loaded, it tries to log you in to the network as a user. If security and the one-time login facility are enabled on your computer you have already given a username and password, so these are used. Otherwise, you must type them now.

In any of the following circumstances a login will not succeed:

These factors can be controlled by any user with workgroup administrator privileges. See "Creating and Modifying User Accounts" on page 20-6.

If you have ever previously logged in and saved your connections to a login script, those connections (to Personal NetWare and NetWare servers, directories and printers) are remade now. See "Saving Connections" on page 21-37 for further details.

After logging in, you can connect to shared directories and printers on Personal NetWare servers, and to their NetWare equivalents: NetWare volumes and NetWare printer queues. These operations are described starting with "Using Shared Directories and NetWare Volumes" on page 21-8.

Eventually, you will want to log out. Refer to "Logging Out" on page 21-40 for information.

Logging In to a NetWare Server or Directory Services Tree

Once the networking software is loaded into your computer's memory, you can log in to NetWare servers or NetWare Directory Services at any time, using the same or a different username
in each.

After logging in, if you save your connections they will be remade the next time you log in to the network.

If you want to run your NetWare login script for the specified NetWare server or tree, use the NetWare LOGIN command. Otherwise, use any of the methods described in the following sections.

Logging In to a Different Workgroup or Account

You can change your workgroup, or use a different account by logging in with the new workgroup name, or username for the account.

NOTE: As with most network functions, you can log in by typing a command line or interactively from the system prompt or MS Windows. The MS Windows NetWare Tools program is, by default, selected by pressing the "hotkey" <F6>. You can change this on the NetWare Settings panel which you see when you choose "Network" in the MS Windows Control Panel.

Logging in from DOS, Non-interactive

Using the command line to log in is the quickest if you are at the system prompt.

Logging in from DOS, Interactive

1. At the system prompt, type

NET <Enter>

The NetWare User program loads, showing the NetWare view. To display online help, press <F1>.

2. If the workgroup, server or tree to which you wish to log in is not listed

2a. Choose Include... from the View menu.

2b. Select the types of connection you are interested in.

2c. If you want to connect to a remote workgroup, choose the <Find workgroup...> button. You may have to wait while the entire network is searched.

2d. Choose the <OK> button to return to the NetWare view.

3. Select your workgroup or the NetWare tree or server to which you wish to log in.

4. Choose Connect... in the File menu or press <Enter>.

The Login dialog appears.

5. If you are logging in to a workgroup, and you want it to become your default workgroup, select Join workgroup.

6. Type your username and password, then choose the <OK> button.

If your account has no password, leave the password blank. When you type a password, asterisks display on the screen. If you think you have made a mistake, press <Backspace>. If you do make a mistake, you must repeat the login procedure.

7. When you have finished using NET, choose Exit from the File menu, or press <Alt> X.

The first time you use NET, you might want to connect to directories and printers before you exit.

Logging in from MS Windows

1. In Program Manager, choose the Personal NetWare icon in the DR-DOS window.

To choose an object, double-click it or highlight it and press <Enter>.

2. Open the NetWare window, unless it is already open.

From the Window menu, choose NetWare, or double-click the NetWare icon in the main window.

3. Choose the <Include non-connected resources in list> button.

Button names are shown along the bottom of the main window when the mouse is over a button.

You may need to make the NetWare window wider to see both sides.

4. All local trees, NetWare servers and workgroups are listed on the right side of the NetWare window. Remote workgroups are not shown. Use one of the following two steps:

4a. For a local workgroup, tree or server, choose the one to which you wish to log in.

4b. For a remote workgroup

The Login dialog appears.

5. Type your username and password, then choose the <OK> button.

If the username and password are correct, you are now logged in. The workgroup, server or tree appears in the left side of the NetWare window to show that you are connected to it.

6. If you have logged in to a different workgroup, and want to make it your default workgroup for the future, choose the <Set Preferred> button on the Workgroup Connection Information dialog.

If the dialog is not open, you can open it by selecting the workgroup, then choosing Properties... from the File menu.

Using Shared Directories and NetWare Volumes

To use shared directories on Personal NetWare servers and volumes on NetWare servers, you must first connect to them. This connection establishes a mapping between a DOS drive letter and the selected directory. Note that in NetWare the term "map" is used for connecting to a volume.

As far as DOS, MS Windows, and applications are concerned, your computer has acquired another hard disk. Note, however, that you may not perform "low-level" operations such as formatting the disk.

You can use shared directories to store shared data and shared applications, or simply to increase the disk space available to your computer. Sharing data is discussed in "Sharing Data on Shared Directories" on page 21-13. Sharing applications is discussed in "Running Applications on Shared Directories" on page 21-14.

Figure 21-1
Sharing Directories

Connecting to Shared Directories

Connections are maintained for as long as you are logged in, or until you delete them, but are lost when you log out unless you have saved them. Refer to "Saving Connections" on page 21-37.

Before you can connect to a shared directory, you must do the following:

CHECKLIST:
* You must log in to the server's workgroup or NetWare server. Refer to
"Logging In" on page 21-2.

* The directory must exist as a shared directory (if it is on a Personal NetWare server) or NetWare volume. Refer to "Sharing Directories" on page 20-24.

* You must have rights to read or write files in the directory. Rights are controlled by the server's owner. Refer to "Sharing Directories" on page 20-24.

Make connections using one of the following three procedures:

Connecting to Shared Directories from DOS, Non-interactive

Use the NET MAP command. See the "NET Commands" chapter of DOSBook for details.

Connecting to Shared Directories from DOS, Interactive

1. At the system prompt, type

NET <Enter>

The NetWare User program loads, showing the NetWare view. To display online help, press <F1>.

2. Choose Drives from the View menu.

The Drive view appears. It shows all your drive letters and whether they are local (physically part of your computer), unused, or already connected over the network to a shared directory or NetWare volume.

3. Refer to the following table to see what to do next.
To

Do this

Connect (map) a drive letter to a shared directory or NetWare volume

1. Highlight the drive letter you want to use. You can select any letter. If the letter is a local drive, that drive will be unusable while the network connection exists, so do not select C: if your computer is a server.

2. Choose Connect... from the File menu or press <Enter>.

If the drive is already connected, you are prompted to confirm that you want to connect it to a different network directory.

3. Select the desired directory from the list that appears.

Change the current directory (CD) of any drive letter.

1. Highlight the drive letter you want to change.

2. Choose Properties... from the File menu

3. Select the desired directory from the list that appears. You can go several levels down the directory tree, if you wish, but you cannot go higher than the shared directory itself, which is treated as a "root" directory.

Disconnect a drive letter from a shared directory or NetWare volume

1. Highlight the drive letter.

2. Choose Disconnect... from the File menu or press <Del>.

Connecting to Shared Directories from MS Windows

NOTE: When first made, connections are not permanent. They last only until you switch off or reboot the computer, unless you make them permanent. See "Make a connection permanent," in the following procedure.

By default, connections are local, not global. This means, for example, that a drive connection is not visible inside a DOS window opened before the connection was made. See "Make connections global" in the following procedure.

There are two ways to connect to shared directories. If you are in File Manager, you can choose the Network Connections... command from the Disk menu. This opens a window almost identical to the one described in Step 3 of the procedure below. Refer to on-line help for a fuller explanation. If you are not in File Manager, use the following procedure.

1. In Program Manager, choose the Personal NetWare icon in the DR-DOS window.

2. Open the Drives window, unless it is already open.

From the Window menu, choose Drives, or double-click the Drives icon in the main window.

Note that the window shows the complete path to the current directory of network connections as:

\\server\volume\dir1\dir2 \<current_dir>

The space indicates the location of the root directory. On Personal NetWare shared directories, this must be at the shared directory itself.

3. If you want to connect to a NetWare 4.x server, and the server's volumes are not shown, change your current context. See "Changing Your NetWare Directory Services Context from MS Windows" on page 21-37.

4. Refer to the following table to see what to do next.
To

Do this

Connect (map) a drive letter to a shared directory or NetWare volume

1. Select the shared directory or NetWare volume from the list on the right side of the window.

2. (Optionally, on NetWare volumes only - not Personal NetWare shared directories) if you want to connect to a subdirectory within the volume, double-click on the icon to open it. Repeat for each level of subdirectory. Select whichever subdirectory you wish to be the root.

3. Drag the selected directory across to the required drive letter, or select the drive letter, then choose Connect... from the File menu. You can select any drive letter. If the letter is a local drive, that drive will be unusable while the network connection exists, so do not select C: if your computer is a server. If the letter is already connected, the existing connection will be deleted.

Connect (map) a drive letter to a shared directory or NetWare volume and set the current directory (CD).

1. Select the directory you want to be the current directory from the list on the right side of the window. If it is not visible, choose (double-click) the shared directory or NetWare volume, then do the same, in turn, to each subdirectory in the path.

2. Select the required drive letter.

3. From the File menu, choose Connect...

4. Edit the Source path field to insert a space between the volume's name and the backslash which follows it. The path up to the space becomes the root path. On NetWare volumes - not Personal NetWare shared directories - this may be a subdirectory within the volume.

5. Choose the <OK> button.

Make a connection permanent

1. Select the connection from the list on the left side of the window.

2. From the File menu, choose Permanent. Note that the Permanent Connections box in the NetWare Settings dialog must be enabled for this to take effect. See "Saving Connections" on page 21-37. Permanent connections are distinguished in the Drives window by having different icons from temporary ones.

You can make a permanent connection temporary by choosing Permanent a second time.

Make connections global

1. From the Main window in Program Manager, choose "Control."

2. In the Control Panel, choose "Network."

3. In the NetWare Settings dialog, select "Global Drives & Paths."

(See also "Task Switching: Local and Global Connections" on page 21-2.)

Display information about a volume

1. Select the shared directory or NetWare volume from the list on the right side of the window.

2. From the File menu, choose Properties...

3. The server type and disk space are displayed.

Display information about a mapped directory

1. Choose the drive letter, or select it and choose Properties... from the File menu.

A dialog is displayed. It tells you whether the drive is local or networked, whether it is searched in your current PATH, and whether the connection is permanent.

Disconnect a drive letter from a shared directory or NetWare volume

1. Select the drive letter.

2. From the File menu, choose Disconnect...

Sharing Data on Shared Directories

In order that several users can read data files at the same time, ensure that

If you try to edit or otherwise modify the file you are denied access to it. To modify a shared data file you must first stop it from being shared by resetting its read-only attribute; then you can modify it before setting it to read-only again. If you are denied access when you try to modify the file, you will know that some other user is reading the file. You could broadcast a message asking them to close it.

Running Applications on Shared Directories

To run an application which has been installed on a Personal NetWare or NetWare server, you may first have to perform some initialization steps on your client computer. These vary greatly from application to application, and should be described in the application's documentation. In general, though, you follow a procedure similar to those described in this section.

If you expect to run the application more than once, you can save time by creating a batch file that automates the procedure. This is described in the second procedure in this section.

If you expect to run the application so frequently that you are willing to dedicate one of your drive letters permanently to it, you can save a little more time by following the third procedure described in this section.

If you use MS Windows, follow the fourth procedure.

NOTE: In all the procedures, an application called THISAPP.EXE in a shared directory called THISDIR on a server called THISSERVER is used as an example. THISAPP will be run on drive M:.

Before you can run an application from a shared directory, you must do the following:

CHECKLIST:
* The application must have been installed as described in
"Sharing an Application" on page 20-30.

* You must log in to the server's workgroup or NetWare server. Refer to "Logging In" on page 21-2.

* You must have rights to read files in the application's directory. Rights are controlled by the server's owner. Refer to "Sharing Directories" on page 20-24.

* Your CONFIG.SYS file must set sufficient FILES and BUFFERS, depending on how many files the application opens simultaneously.

Find out if the application has a different way to configure the number of open files. Clipper*-compiled applications often have a separate configuration method.

If you need to change the number of FILES or BUFFERS, use SETUP to edit CONFIG.SYS, then reboot the computer for the changes to take effect.

Running a Shared Application Once

To run a shared application once, do the following:

1. Connect a suitable drive letter to the application's directory on the server.

Follow the procedure described in "Connecting to Shared Directories" on page 21-9. Some applications may have been installed so that they can only be run on a specific drive letter, but often the choice is yours.

2. Make the application's drive letter the current drive.

This is not needed by all applications, but, for example, in the THISAPP example you would type the following at the system prompt:

M: <Enter>

3. Give the command to run the application.

For example, in the THISAPP example you would type

THISAPP <Enter>

From MS Windows, you could double-click on THISAPP.EXE in the File Manager.

Creating a Batch File To Run a Shared Application

To create a batch file to run a shared application, do the following:

1. Use EDIT or any other text file editor to create the batch file.

The batch file could be called, say, RUNAPP.BAT. This file should be on your own hard disk in a directory named in your PATH command. Its contents could be as follows:

NET MAP M: THISSERVER\THISDIR

M:

THISAPP

NET MAP DEL M:

You can run this batch file at any time while you are logged in to the workgroup.

The NET MAP command is explained in the "NET Commands" chapter of DOSBook.

2. Enter the command to run the application (via the batch file).

For example, in the THISAPP example you would type

RUNAPP <Enter>

From MS Windows, you could double-click on RUNAPP.BAT in the File Manager, or create a program item to run RUNAPP.BAT from the Program Manager.

This method is not suitable for MS Windows applications.

Assigning a Drive Letter to a Shared Application

To dedicate a drive letter to a shared application, do the following:

1. Connect a suitable drive letter to the application's directory on the server.

Follow the procedure described in "Connecting to Shared Directories" on page 21-9. Some applications may have been installed so that they can only be run on a specific drive letter, but often the choice is yours.

2. Save connections.

Follow the procedure described in "Saving Connections" on page 21-37.

3. Use EDIT or any other text file editor to edit AUTOEXEC.BAT.

Add the application's drive letter to the end of the PATH statement. For example, if the original line is

PATH C:\;C:\DRDOS;C:\NWCLIENT

change it to

PATH C:\;C:\DRDOS;C:\NWCLIENT;M:

4. At the system prompt, type the command to run the application.

For example, in the THISAPP example you would type

THISAPP <Enter>

Using MS Windows to Run a Shared Application

1. Connect a suitable drive letter to the application's directory on the server. Make the connection permanent.

Follow the procedure described in "Connecting to Shared Directories" on page 21-9. Some applications may have been installed so that they can only be run on a specific drive letter, but often the choice is yours.

2. In Program Manager, create a program item for the application. Set the Working Directory to the mapped drive letter.

3. To run the application, double-click on its icon in Program Manager.

Using Shared Printers and NetWare Print Queues

To use shared printers on Personal NetWare servers and NetWare print queues, you must first connect to them. This connection establishes a mapping between a printer port and the selected printer's queue. Note that in NetWare the term "capture" is used for connecting to a printer.

As far as DOS and MS Windows applications are concerned, the printer is connected to the port on your computer.

Figure 21-2
Sharing Printers

Connecting to a Printer

Follow one of the three procedures below, depending on your preferences and whether you are using MS Windows.

Before you can connect to a shared printer, you must do the following:

CHECKLIST:
* You must log in to the server's workgroup or NetWare server. Refer to
"Logging In" on page 21-2.

* The printer must be a shared printer (if it is on a Personal NetWare server) or NetWare print queue. Refer to "Sharing Printers" on page 20-32.

* You must have rights to use the printer. Rights are controlled by the server's owner. Refer to "Sharing Printers" on page 20-32.

Connecting to a Printer from DOS, Non-interactive

Use the NET CAPTURE command. See the "NET Commands" chapter of DOSBook for details.

Connecting to a Printer from DOS, Interactive

1. At the system prompt, type

NET <Enter>

The NetWare User program loads, showing the NetWare view. To display online help, press <F1>.

2. Choose Printers from the View menu.

The Printer Port view appears. For each of your printer ports this shows whether they are already connected over the network to a shared printer or NetWare print queue.

3. Refer to the following table to see what to do next.
To

Do this

Connect (capture) a port to a shared printer or NetWare print queue

1. Select the port you want to use. You can select any number. If there is a printer physically attached to that port on your computer, that printer will be unusable while the network connection exists. If the port is already connected to a different shared printer, the existing connection is broken, if you choose to connect the port to a different printer when prompted.

2. Choose Connect... from the File menu or press <Enter>.

3. Select the desired shared printer or NetWare print queue from the list that appears, then choose the <OK> button.

4. Change the port settings as described next.

Change the settings of a port

1. Select the port.

2. Choose Properties... from the File menu or press <Alt><Enter>.

3. Make any changes you need in the Printer Settings dialog, described in the following table.

Note these important settings for PostScript* printers: No form feed, tab expansion or banner.

Disconnect a port from a shared printer or NetWare print queue

1. Select the port.

2. Choose Disconnect... from the File menu or press <Del>.

The Printer Settings dialog has the following fields:
Field

Purpose

AutoEndcap

(Automatic End Capture) Automatically closes each print job when the application that created the job terminates.

Banner

Prints a full page banner before each job to identify the username and job or filename.

Make sure Banner is not selected for PostScript printers.

If you use MS Windows, you can set the banner text with NetWare Tools.

Direct

Specifies whether the printer should start printing the job before it has been closed. The potential danger in this is that if the client never closes the job, and if Printer wait is set to zero, no-one else can use the printer.

Form Feed

Sends a form feed character to the printer at the end of each job to make it eject the last page.

Make sure Form Feed is not selected for PostScript printers.

Keep

This option can only be set using the MS Windows NetWare Tools. If selected, jobs which have been partly sent when the client-server connection is broken are kept in the queue.

Job hold

Stops print jobs from printing until you explicitly release them. Until then, the jobs will remain in the printer's queue. See "Viewing and Changing Print Queues" on page 21-25.

Notify

Pops up a message on your screen when each of your print jobs finishes printing, so you know when to go to collect the printout.

Form name

Allows you to specify which of several paper types should be used. When one of your jobs is ready to print, a message pops up on the screen of the Personal NetWare server, asking its user to load the requested paper into the printer.

This field is blank if the printer has no forms defined for it.

You can specify which form is currently in the printer. See "Viewing and Changing Printer Status and Forms" on page 21-28.

Setup string

Allows you to specify which of several setup strings should be used. The setup string, if used, is sent to the printer before each of your jobs.

This field is blank if the printer has no setup strings defined for it.

Copies

You can ask for up to 250 copies. Copies are not collated.

Tab expansion

You can specify how many spaces the tab character should be replaced by.

Make sure this is set to zero for PostScript printers.

Timeout /
Printer wait (seconds)

Sets the time for which the printer waits before deciding that a job is finished, if no more output is received during that time.

A wait of zero is taken to mean "forever."

Connecting to a Printer from MS Windows

There are two ways to connect to shared printers. If you are in Print Manager, you can choose the Network Connections... command from the Options menu. This opens a window almost identical to the one described in Step 3 of the procedure below. Refer to online help for a fuller explanation. If you are not in Print Manager, use the following procedure.

NOTE: If Print Manager is enabled and you select Print Net Jobs Direct, you get the best performance without losing the ability to view and control queues. Print Net Jobs Direct is in the Network Options dialog which you open by choosing Network Settings... from the Options menu of Print Manager.

1. In Program Manager, choose the Personal NetWare icon in the DR-DOS window.

2. Open the Printers window, unless it is already open.

From the Window menu, choose Printers, or double-click the Printers icon in the main window.

3. If you want to connect to a NetWare 4.x server, and the server's printers are not shown, change your current context. See "Changing Your NetWare Directory Services Context from MS Windows" on page 21-37.

4. Refer to the following table to see what to do next.
To

Do this

Connect (capture) a port to a network printer

1. Select the printer from the list on the right side of the window.

2. Drag it across to the required port, or select the port, then choose Connect... from the File menu. You can select any port. If the port has a local printer attached to it, that printer will be unusable while the network connection exists. If it is already connected, the existing connection will be closed.

3. Verify and, if needed, change the port settings. See "Change the settings of a port," below.

When first made, connections are not permanent. They last only until you quit MS Windows. See "Make a connection permanent," below.

By default, connections are local, not global. This means, for example, that a connection is not visible inside a DOS window opened before the connection was made. See "Make connections global" on page 21-12.

Change the settings of a port

1. Select the port (from the left side of the window).

2. From the File menu, choose Properties...

3. Make any changes you need in the Printer Settings dialog, described on page 21-21.

Note the important settings for PostScript printers: No form feed, tab expansion or banner.

Make a connection permanent

1. Select the connection from the left side of the window.

2. From the File menu, choose Permanent. Note that the Permanent Connections box in the NetWare Settings dialog must be enabled for this to take effect. See "Saving Connections" on page 21-37. Permanent connections are distinguished in the Printers window by having different icons from temporary ones.

You can make a permanent connection temporary by choosing Permanent a second time.

Make connections global

1. From the Main window in Program Manager, choose "Control."

2. In the Control Panel, choose "Network."

3. In the NetWare Settings dialog, select "Global Drives & Paths."

(See also "Task Switching: Local and Global Connections" on page 21-2.)

Disconnect a port from a network printer

1. Select the port.

2. From the File menu, choose Disconnect...

Notes

After connecting to a shared printer, you can use the corresponding port name (LPT1, for example) in practically all DOS commands and within all applications. As output goes into a print queue, you may wish to see the contents of each print queue, and re-order it, or change the settings of any of your jobs in the print queue. Refer to "Viewing and Changing Print Queues" on page 21-25 for information about this.

The connections are maintained for as long as you are logged in, but are lost when you log out unless you have saved them or made them permanent. Refer to "Saving Connections" on page 21-37 for information about saving connections.

Each print job is closed when any of the following occurs:

Printing a File

You can print a file on a shared printer using the following methods:

Viewing and Changing Print Queues

Because a print job goes into a print queue before it is printed, you can change its settings up to the point when it starts printing. You can add a file to the queue, change the order of your jobs in the queue, put them on hold, or delete the job.

You cannot do all these tasks using MS Windows Print Manager. You may need to use the NET program.

Before you can view a print queue, you must do the following:

CHECKLIST:
* You must log in to the server's workgroup or NetWare server. Refer to
"Logging In" on page 21-2.

* You must have workgroup administrator privileges to control other users' print jobs.

Using Print Queues from DOS

1. At the system prompt, type

NET <Enter>

The NetWare User program loads, showing the NetWare view. To display online help, press <F1>.

2. Choose Select Print Queue... from the Printing menu.

3. Select the required printer or queue from the list.

The Printer Queue view appears. This shows all the jobs currently in the selected queue.

4. Refer to the following table to see what to do next.
To

Do this

Add a file to the queue

1. Choose Print file... from the Printing menu or press <Ins>.

2. Type the file's name in the Print File dialog.

For PostScript printers, the file must contain PostScript.

If you have connected a port to this printer, your connection settings are used. If not, one copy of your file is printed with no banner, no notification, default form, final form feed. While the job is in the queue you can change these.

Change the settings of a print job

1. Select the job.

2. Choose Job settings... from the Printing menu or press <Enter>.

3. Make any changes you need in the Printer Job Settings dialog, described below.

Change the status of a print job between "holding" and "ready"

1. Select the job.

2. Choose Job settings... from the Printing menu or press <Enter>.

3. Change the Job Hold field in the Printer Job Settings dialog.

Change the order of jobs in the queue

1. Select the job you want to move. You can only move your own jobs.

2. Choose Move job... from the Printing menu.

3. Type the new job number. Jobs are printed in number order.

Delete a print job

1. Select the job.

2. Choose Delete job... from the Printing menu or press <Del>.

View the queue of a different printer

1. Choose Select print queue... from the Printing menu.

The Printer Job Settings dialog's fields are similar to those in the Printer Settings dialog (see the table on page 21-21) except that the Print Job Settings dialog does not have the AutoEndcap, Direct, Setup string and Printer wait fields.

Viewing Print Queues from MS Windows: Using Print Manager

If Print Manager is enabled, you can use it to view queues and delete your jobs from them. You enable or disable Print Manager on the Printers dialog box in the MS Windows Control Panel. Print Manager shows all your jobs in the queue, even if they were created while Print Manager was disabled.

If Print Net Jobs Direct is selected you cannot change the order of jobs in a queue with Print Manager, but you can with NET (see the previous procedure).

1. Start the Print Manager from Program Manager.

Refer to online help if you are not familiar with Print Manager.

2. View and reorder queues, hold, resume or delete any of your jobs, as required.

Viewing Print Queues from MS Windows: Using Personal NetWare

1. In Program Manager, choose the Personal NetWare icon in the Personal NetWare window.

2. Open the Printers window, unless it is already open.

From the Window menu, choose Printers, or double-click the Printers icon in the main window.

3. In the Printers window, choose the printer or port
(double-click, or select and press <Enter>).

The printer's queue window opens, showing all jobs in the queue.

To

Do this

Put one of your jobs on hold, or take it off hold

1. Select the job.

2. Choose the <Pause> or <Resume> button, as appropriate.

Note that the job's icon changes color. Paused jobs are not printed, but remain in the queue indefinitely.

Delete one of your jobs

1. Select the job.

2. Choose the <Delete> button.

Close the window

1. Choose the <Close> button.

Viewing and Changing Printer Status and Forms

You can view and change the status of shared printers attached to Personal NetWare servers (but not NetWare servers). The status is either "Printing" or "Holding."

If the printer supports several named forms, you can specify which is currently loaded.

Note that you must use the NET utility to perform these functions - not the MS Windows Print Manager.

Before you can view or change the status of printers, you must do the following:

CHECKLIST:
* You must log in to the server's workgroup. Refer to
"Logging In" on page 21-2.

* You must have workgroup administrator privileges.

To view or change the status of a printer or form, do the following:

1. At the system prompt, type

NET <Enter>

The NetWare User program loads, showing the NetWare view. To display online help, press <F1>.

2. Choose Select Print Queue... from the Printing menu.

3. Select the required printer from the list.

The Printer Queue view appears. This shows all the jobs currently in the selected queue.

4. Choose Printer status... from the Printing menu.

5. Change the status field, or specify the current form.

Sending Messages to Other Users

You can send a one line message to any or all workgroup users or users logged in to a NetWare server. This can be very useful if you are a server's owner and want to draw other users' attention to a new or changed setting, for example.

Users can stop messages from appearing on their screens, so your message might not get through. Users only see messages when they are logged in. Messages are not held until the user logs in.

Before you can send a message to another user, you must log in to the same workgroup or NetWare server as the other user. Refer to "Logging In" on page 21-2.

Sending Messages from DOS, Non-interactive

Use the NET SEND command. See the "NET Commands" chapter of DOSBook for details.

Sending Messages from DOS, Interactive

1. At the system prompt, type

NET <Enter>

The NetWare User program loads, showing the NetWare view. To display online help, press <F1>.

2. Choose Send message... from the File menu.

3. Select the workgroup or NetWare server from the list of servers.

4. Select "All connected users" or one or more usernames by highlighting each name and pressing <Spacebar> to select them.

Only logged-in users are shown in the list.

5. Type the message in its field.

You do not need to include your username, as this is added automatically.

6. Choose the <OK> button to send the message.

Remember that you cannot be sure that a user has not disabled message reception. Your message might not be seen.

Sending Messages from MS Windows

1. In Program Manager, choose the Personal NetWare icon in the Personal NetWare window.

2. Open the NetWare window, unless it is already open.

From the Window menu, choose NetWare, or double-click the NetWare icon in the main window.

3. In the left side of the window, select the workgroup, user or group of users to whom you want to send a message

To see USERS, make sure the <Include users in lists> button is selected, and double-click the workgroup or server to display logged-in users.

To see GROUPS, make sure the <Include groups in lists> button is selected, and double-click the NetWare server to display logged-in groups. (Groups are defined only on NetWare servers.)

4. From the File menu, choose Properties...

5. Type your message in the Message field.

6. Choose the <Send> button.

Receiving Messages from Other Users

If a user sends a message to you while you are logged in, it appears on your screen, unless you have turned off message reception, as described below.

If your screen is in text mode, the message replaces the top line of the display. You must press <Ctrl><Enter> to remove it. Anything you type before pressing <Ctrl><Enter> is lost. It does not go to the application you are currently running. When you press <Ctrl><Enter>, the message disappears, the original top line reappears, and you can continue with whatever you were doing.

If you are running MS Windows, the message appears as a pop-up window in the center of the screen. The window has an <OK> button. You must click on it or press <Enter> to close the window and continue.

Controlling Message Reception

You can stop messages from being displayed, or set a timeout value so that the message is only displayed for a short time.

Controlling Message Reception from DOS

1. At the system prompt, type

NET <Enter>

The NetWare User program loads, showing the NetWare view. To display online help, press <F1>.

2. Choose Message reception... from the File menu.

3. Select or deselect <Receive messages>.

4. If you select <Receive messages>, you can enable a timeout.

5. If you select <Use timeout>, you can specify a timeout in seconds.

With no timeout, a message stays on the screen indefinitely, until the user removes it. With a timeout, the message disappears if the user has not already cleared it after the time has expired.

Controlling Message Reception from MS Windows

1. Either

1a. Press the Network Hotkey (<F6> by default) then choose "NetWare Settings..." (<Alt> S), or

1b. Choose "Network" from the Control Panel.

2. In the NetWare Settings dialog, select or deselect Broadcasts in the Message Reception area.

Viewing Your Account Details

You can display the details of your own account. The details shown include:

Before you can view your account details, you must log in to the workgroup. Refer to "Logging In" on page 21-2.

Viewing Your Account Details from DOS

1. At the system prompt, type

NET <Enter>

The NetWare User program loads, showing the NetWare view. To display online help, press <F1>.

2. Choose Show account... from the File menu.

The details of your account are shown. You cannot change them. Their meanings are explained in "Creating and Modifying User Accounts" on page 20-6.

Viewing Your Account Details from MS Windows

1. In Program Manager, choose the Personal NetWare icon in the Personal NetWare window.

2. Open the NetWare window, unless it is already open.

From the Window menu, choose NetWare, or double-click the NetWare icon in the main window.

3. In the left side of the window, double-click your workgroup to display usernames.

Make sure the <Include users in lists> button is selected.

4. Select yourself from the list.

5. From the File menu, choose Properties...

6. Choose the <Configure> button.

The User Account Configuration dialog displays. The information it shows is described in "Creating and Modifying User Accounts" on page 20-6.

Changing Your Password

If your account has a password which you are allowed to change, change it regularly, even if the account properties do not specify that you must.

If you have an account in several workgroups or on several NetWare servers you could have a password for each account. One-time login demands that all your accounts have the same password and username. Also, to be practical, it is very difficult to remember several passwords. Therefore, change all your accounts' passwords at the same time, and keep them the same as each other.

Before you can change your password, you must do the following:

CHECKLIST:
* You must log in to the workgroup or NetWare server of your account. Refer to
"Logging In" on page 21-2.

Changing Your Password from DOS, Non-interactive

To change your workgroup password, use the NET SETPASS command. See the "NET Commands" chapter of DOSBook for details.

To change your password on a NetWare server or tree, use the NetWare SETPASS command. Refer to your Novell NetWare documentation for details.

Changing Your Password from DOS, Interactive

1. At the system prompt, type

NET <Enter>

The NetWare User program loads, showing the NetWare view. To display online help, press <F1>.

2. Highlight the workgroup or NetWare server on which you want to change password.

3. Choose Properties... from the File menu.

4. Type in your new password, press <Tab>, repeat the password.

If you are changing your password on a NetWare server, you must type in the old password first.

5. Choose the <OK> button to commit to the new password.

Your account details may impose a minimum length on your password. Use the Show account... command from the File menu to find out what the minimum length is.

Changing Your Password from MS Windows

1. In Program Manager, choose the Personal NetWare icon in the Personal NetWare window.

2. Open the NetWare window, unless it is already open.

From the Window menu, choose NetWare, or double-click the NetWare icon in the main window.

3. In the left side of the window, select yourself in the list of users under the workgroup or server where you want to change your password.

To see USERS, make sure the <Include users in lists> button is selected, and double-click the workgroup or server to display logged-in users.

4. From the File menu, choose Properties...

Your User Information dialog appears.

Your account details may impose a minimum length on your password. To find out if this is the case, display your account details by choosing the <Configure...> button.

5. Choose the <Set Pass...> button.

6. Type your old and new passwords into the boxes provided, then choose the <OK> button.

7. Choose the <Close> button to close the User Information dialog.

Changing Your NetWare Directory Services Context

This is only of concern to users on NetWare 4.x networks. This section does not apply to any other user.

Within NetWare Directory Services you have a "current context." This is a node in the tree within which the NET utility searches for servers and users. You can change the current context in order to broaden, narrow, or simply change the part of the tree that will be searched.

If you set your current context to the root of the tree, searches may take a long time and include lots of servers in which you have no interest, so you should normally set the current context to include just the part of the tree that contains the resources you actually want to use.

Before you can change your context, you must log in to NetWare Directory Services. Refer to "Logging In" on page 21-2.

Changing Your NetWare Directory Services Context from DOS, Non-interactive

Use the NET CONTEXT command. See the "NET Commands" chapter of DOSBook for details.

Changing Your NetWare Directory Services Context from DOS, Interactive

1. At the system prompt, type

NET <Enter>

The NetWare User program loads, showing the NetWare view. To display online help, press <F1>.

2. Choose Current context... from the File menu.

The Directory Services dialog appears. It shows the current organization "O=" and organization unit "OU=" with the smallest unit shown first.

3. To go down the tree, choose a container from the list. To go up, choose "..".

Changing Your NetWare Directory Services Context from MS Windows

1. In Program Manager, choose the Personal NetWare icon in the Personal NetWare window.

The NetWare, Drives and Printers window in Personal NetWare all show the current context. The context is shown alongside an icon which is either an organization icon if the context is the root of the tree, or an up-arrow.

2. To go up the tree, choose the up-arrow icon in any window.

3. To go down the tree, choose the tree, organization or organization unit you want to open.

Saving Connections

You can save all your current connections to shared directories and printers on Personal NetWare and NetWare servers, so that they are reconnected automatically when you next log in. The NET SAVE command also allows you to create a batch file which contains the same connection commands. You can execute the batch file when you need to remake the connections.

Note that if a task switcher is running, only connections that exist in the current task (including those you made before you started the task switcher), are saved.

Saving Connections from DOS, Non-interactive

1. You can save connections either as a login script, which is executed automatically when you next log in, or as a batch file which you can execute on demand. In either case the contents are identical, but the filename and location are not.

1a. To save a login script, type the following at the system prompt:

NET SAVE /S <Enter>

See "Saving Connections from DOS, Interactive," below, for details of the script file created.

1b. To create a batch file, type the following at the system prompt:

NET SAVE [[path\]filename.BAT] <Enter>

If you omit the filename, NWLOGIN.BAT is created. By default it is in the current directory on the current drive. See "Saving Connections from DOS, Interactive," below, for details of the contents of the batch file created.

Saving Connections from DOS, Interactive

1. At the system prompt, type

NET <Enter>

The NetWare User program loads, showing the NetWare view. To display online help, press <F1>.

2. Choose Save script... from the File menu.

All your current connections are saved to a login script file (in C:\NWCNTL\MAIL by default) which is executed the next time you log in. Its name is unique to your workgroup username. Current connections include any made within MS Windows.

The file contains the following types of statement:

3. (Optionally) use the Edit script... command from the File menu to edit the script file, if needed.

Saving Connections from MS Windows

Selected connections can be remade each time you restart MS Windows. Note that connections are not closed when you exit from MS Windows to DOS. The NET SAVE command described above can be used after you exit from MS Windows if you wish to remake the connections when you next log in, without needing to start MS Windows.

1. Each drive and printer connection can be made permanent, or left as temporary, by choosing Permanent from the File menu in the Personal NetWare program.

Note how the connection's icon changes. Temporary connections' icons are gray rectangles.

Choosing <Permanent> a second time makes the connection temporary again.

2. Select the "Permanent" box in NetWare Settings to enable reconnections.

Reach the NetWare Settings dialog from the Network icon in the MS Windows Control Panel.

Logging in Using Saved Connections

If you have a login script on the computer at which you are working, logging in runs it automatically. If you have the same username and password in your workgroup and on each NetWare server and tree to which you log in, you need only type the name and password once.

If you use MS Windows and selected <Permanent> in NetWare Settings, the next time you start MS Windows those connections you made permanent will be remade. If this requires logging in to any servers, you are prompted for your password. Instead of giving a password, you can choose the <Cancel> button, then either the <Skip> button to omit the connection for this session, or the <Remove> button to delete it permanently.

Logging Out

The best way to disconnect from the network is to type a NET LOGOUT command. This immediately tells all servers that your connections are closed. This allows server owners to see that there are no connections to their server, and switch the server off or reboot it without causing data loss or corruption.

If you switch off or reboot your computer while you are logged in to the network, the system eventually realizes that your computer is not responding and logs you out. Meanwhile, server owners cannot switch their computers off confidently, so it is recommended that you always log out explicitly, if possible.

You can also selectively disconnect from any workgroup or server, leaving your other connections open.

Logging Out from DOS, Non-interactive

Use the NET LOGOUT command. See the "NET Commands" chapter of DOSBook for details.

Logging Out from DOS, Interactive

1. At the system prompt, type

NET <Enter>

The NetWare User program loads, showing the NetWare view. To display online help, press <F1>.

2. Highlight the workgroup or NetWare server from which you want to log out.

3. Choose Disconnect... from the File menu, or press <Del>.

Logging Out from MS Windows

1. In Program Manager, choose the Personal NetWare icon in the Personal NetWare window.

2. Open the NetWare window, unless it is already open.

From the Window menu, choose NetWare, or double-click the NetWare icon in the main window.

3. In the left side of the window, select the workgroup or server from which you want to log out.

4. From the File menu, choose Logout.

Closing Down Your Server

WARNING: If your computer is a server, you can inadvertently cause other users to lose information and time if you switch it off or reboot it while they are using its shared files or printers. To minimize the possibility of this, the server intercepts the <Ctrl><Alt><Del> reboot command. It displays a pop-up window, informing you of the number of open connections and files. Unless these numbers are zero, you should not continue with rebooting.

However, if they have AUTO.VLM loaded, clients have some protection against short disconnections. If the server loses power for a few moments, or is rebooted, AUTO.VLM attempts to remake connections to it when it becomes available again.

Before you can close down the server, you must log in to your server's workgroup. Refer to "Logging In" on page 21-2.

The best procedures for closing down your server, before you attempt to reboot it or switch it off, are as follows.

Closing Down a Server from DOS

1. At the system prompt, type

NET DOWN <Enter>

If there are no active connections other than your own, this closes your server. You can now reboot your computer or switch it off.

If there are active connections, NET DOWN warns you. It allows you to close the server anyway, but offers the choice of not doing so. It is safest to do the following.

2. At the system prompt, type

NET CONSOLE <Enter>

The NET CONSOLE program's window appears. It shows full details of users and their connections, and allows you to broadcast a message to them.

3. Send a message to active users.

Assuming they respond by closing their files, you can safely close the server.

4. Exit from NET CONSOLE.

5. At the system prompt, type

NET DOWN <Enter>

Closing Down a Server from MS Windows

1. In Program Manager, choose the Personal NetWare icon in the Personal NetWare window.

2. Open the NetWare window, unless it is already open.

From the Window menu, choose NetWare, or double-click the NetWare icon in the main window.

3. In the left side of the window, double-click your workgroup to display servers.

4. Select your server.

5. From the File menu, choose Properties...

In the Server Information dialog, you can see if there are any connected users (other than yourself).

6. For each connected user
To

Do this

Send the user a message

1. In the NetWare window, select the user.

2. From the File menu, choose Properties...

3. In the User Information dialog, type the message, then choose the <Send> button.

See if the user has any open files on your server

1. Select the user from the list on the Server Information dialog.

2. Choose the <Open Files> button.

Disconnect the user

1. Choose the <Disconnect User> button on the Server Information dialog.

Note that you cannot disconnect yourself this way.

7. When you are satisfied that no other user has open files on your server it is safe to reboot or switch off your computer.



[Front] [Prev Chapter] [Next Chapter]

info@caldera.com
Copyright © 1993, 1997, 1998 Caldera, Inc. All rights reserved.